Tiingo Inc - Upstream Data Provider for FX is experiencing technical issues – Incident details

Upstream Data Provider for FX is experiencing technical issues

Resolved
Degraded performance
Started 6 months agoLasted about 6 hours

Affected

Tiingo API

Partial outage from 12:51 PM to 2:34 PM, Degraded performance from 2:34 PM to 6:35 PM

FX Prices Endpoint

Partial outage from 12:51 PM to 2:34 PM, Degraded performance from 2:34 PM to 6:35 PM

Updates
  • Resolved
    Resolved

    Upstream FX Broker has resolved their technical issues. Spreads remain back to normal.

  • Monitoring
    Monitoring

    We have implemented a temporary fix that will result in price updates, with bid/asks potentially being wider; however, mid prices should remain approximately in-line.

  • Identified
    Identified

    Upstream data provider for FX rates is experiencing technical issues resulting in limited price updates for FX currencies.