Scheduled for May 07, 2026 at 1:00 AM – 6:56 AM
Affects
Tiingo API
Under maintenance from 1:00 AM to 6:56 AM
Tiingo API Website
Under maintenance from 1:00 AM to 6:56 AM
Tiingo App
Under maintenance from 1:00 AM to 6:56 AM
Completed
May 07, 2026 at 6:56 AMCompleted
In progress
May 07, 2026 at 1:00 AMIn progress
May 07, 2026 at 1:00 AMMaintenance is now in progress
Update
May 07, 2026 at 1:00 AMUpdate
May 07, 2026 at 1:00 AMOn May 6th 01:00-09:00 UTC Tiingo will be undergoing a large data center migration for a large portion of our stack. During this time, the Tiingo API WILL REMAIN accessible.
However the Tiingo.com front-end and Tiingo Web App (app.tiingo.com) will remain inaccessible.
We expect a seamless transition, with minimal to no downtime.
Planned
May 07, 2026 at 1:00 AMPlanned
May 07, 2026 at 1:00 AMWe have moved up this migration to Wednesday May 6th at 9pm ET - 4pm ET. We do not anticipate any API downtime. User registration and web UI will have limited access, but API - both REST and WebSockets - will remain fully functional.