Tiingo Inc - Delay in EOD Data for 2026-03-30 – Incident details

Delay in EOD Data for 2026-03-30

Resolved
Degraded performance
Started about 1 month agoLasted about 2 hours

Affected

Tiingo API

Degraded performance from 11:18 PM to 1:46 AM

End-of-Day Prices Endpoint

Degraded performance from 11:18 PM to 1:46 AM

Updates
  • Postmortem
    Postmortem

    Earlier today we launched a massive update to our corp actions processing to boost coverage and reliability. This required jobs to be run after market close which delayed our EOD prices. This was a one-off event.

  • Resolved
    Resolved

    Prices are back to normal schedules

  • Monitoring
    Monitoring

    Prices are loading now